I tried to install it. First the ./configure command fails :
checking for Subversion headers... not found
configure: error: Subversion headers are required. Try --with-svn-include.

I installed the package libsvn-dev to resolve dependencies, but I bump into another error :
checking for PACKAGE... configure: error: Package requirements (glib-2.0 >= 2.6.0
gtk+-2.0 >= 2.6.0
libgnome-2.0 >= 2.6.0
libgnomeui-2.0 >= 2.6.0
gnome-vfs-2.0 >= 2.9.0
libglade-2.0 >= 2.4.0
bonobo-activation-2.0 >= 1.0.0) were not met:

No package 'libgnome-2.0' found
No package 'libgnomeui-2.0' found
No package 'gnome-vfs-2.0' found
No package 'gnome-vfs-module-2.0' found
No package 'libglade-2.0' found
No package 'bonobo-activation-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

And this one, I have no clue howto solve it.But I will search for a solution. I should have search first. some package should be installed too:
sudo apt-get install libgtk2.0-dev libgnomeui-dev libgnomevfs2-dev libglade2-dev libnautilus-extension-dev

now configure works but make fails :(

I'm a bit worry since the roadmap is clearly out of date.